Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2008

    Raytrace Could Not Be Completed - Plus Page Setup / Printer Problem

    I am using:
    Brand new Dell XPS
    Intel Core i7 920 @ 2.67GHz
    6GB DDR3 tri-channel
    Dual 300GB WD Velociraptor HDD in RAID0
    Nvidia GTX285 @ 2560x1600
    Vista Ultimate SP1 (64-bit)
    Chief Architect X2 latest update (12.4)

    My issues are not new. They have been pervasive since I have set this machine up in late April.

    First, Raytracing was failing with the "Raytrace could not be completed" error. I narrowed it down to a grass texture that was creating the problem.

    For anyone dealing with this error, I recommend using these steps to locate the offending material/texture:

    1. Open your render view
    2. Turn off all the layers for the camera view
    3. Turn on just a few layers and Raytrace
    4. Repeat step 3 with more and more layers until you get the error
    5. Once you narrow down the layer, edit each material associated with that layer and see which one will not give you a raytrace preview (last tab in the 'Define Material' window)

    It only took me about 5 minutes to find the offending grass texture using this method. As for the problem, it was fixed by switching CAX2 to run as an Administrator, but this created a new problem (discussed below).

    I found a solution to the raytrace error that does not require running as Administrator. Once I had located the offending JPG file, I saved it under a new name and modified my texture to use that new JPG. I don't know what is wrong with the original JPG but even opening the image and saving it over itself would not eliminate the problem. Now that I have my new JPG file under a different name (make sure your default textures don't reference the bad JPG) the raytrace works fine even without CAX2 running as Administrator.

    Now for my next problem. When I run CAX2 as Administrator, I get a new issue with printers. On any plan file or layout, I can select File -> Print -> Page Setup and nothing happens. The window never comes up. Also, if I choose to print the drawing and click on Properties for my printer nothing will come up. I can't change my PDF printer to select D-size paper because of this. The error only happens when running as Admin.

    Now that I have solved my Raytrace error while running CA without Admin privileges, I can Raytrace and change printing preferences/page setup without any trouble. I know everyone recommends running Chief as an Admin, but in my case it just doesn't work, and I have not found any unique issues with running it this way...yet. I just wanted to post my experiences for everyone else, and hopefully give the Chief Architect team a little more info if they are trying to resolve these issues.

    Thank You

    I know you guys are probably working on it, but please find a way to speed up sending 3D views to layout on the i7 machines.
    Mike Moran
    Lancaster Craftsmen Builders

  2. #2
    Join Date
    May 2006
    In front of my computer
    Good tips. Thanks, Mike.

  3. #3
    Join Date
    Jan 2000
    You shouldn't need to run as administrator. But then you shouldn't have problems printing when running as administrator either.

    I have on occasion seen printing fail as you describe, but rebooting the computer always fixed it.
    Doug Park
    Principal Software Architect
    Chief Architect, Inc.



Posting Permissions

  • Login or Register to post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts